注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

WA!Peter

广州天河, 香港火炭,深圳罗湖, 北京国贸

 
 
 

日志

 
 

Linux + Android SDK note (OK on Ubuntu 11.4 + Sun JDK1.6)  

2011-07-01 18:12:57|  分类: linux |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
- CentOS 5.6  is running on GLIBC 2.5, which does not support Android SDK start
  (can download, can install, but cannot launch emulator)
  note:  error message is like:  libc.so.6 error require GLIBC_2.7, and we don't want to build
  Android SDK from scratch

- Ubuntu 11.4 (probably Debian too) is using newer version of GLIBC, so it runs the official Android SDK, but it
  does not come with the standard Sun JDK6 (1.6), so we need something like this:
#######

add-apt-repository "deb http://archive.canonical.com/ lucid partner"

apt-get update

apt-get install sun-java6-jdk sun-java6-plugin

update-java-alternatives -s java-6-sun

########
during the installation, you will need to say "Y" for the license agreement etc, and one of the step
require you to press "Tab" to go to "OK" button and press "Enter".
ref: http://blog.cheyingwu.tw/index.php/2010/05/02/ubuntu-10-04-switch-to-sun-jdk/
ref on Ubuntu release note: https://wiki.ubuntu.com/LucidLynx/ReleaseNotes#Sun_Java_moved_to_the_Partner_repository

Use:  java -version    AND  javac -version to double check the Sun JDK installation.
Afterall, you can run android-sdk-linux_x86/tools/android, create virtual device and launch it.
(tested: Android 2.1 update and 3.1)

Extra note:   Ubuntu 11.4 is by default using ext4, recommend to use ext3 for backward
compatible, in case we switch back to older CentOS or RedHat.
  评论这张
 
阅读(608)| 评论(1)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017